с программированием:
Напишите программу, которая выводит последнее слово переданной её символьной строки. Слово – это последовательность непробельных символов, ограниченная пробелами или концами строки.
Входные данные
Входная строка содержит произвольную последовательность символов.
Выходные данные
Программа должна вывести последнее слово этой строки.
Примеры
входные данные
Abra babra cadabra
выходные данные
cadabra
Сделал похожую программу, только там нужно было вывести первое слово строки, вот ее код:
program p66;// название программы
var s:string;// описание переменной s (строки)
begin//начало блока программы
read(s);//ввод данных (строки)
if pos(' ',s)<>0 then //оператор выбора определяющий из одного слова строка или нет, если pos равно 0, то слово одно
write (copy(s,1,Pos(' ',s)-1))//если нет то вывод копии строки с 1 символа по позицию пробела минус 1 символ
else write (s)//если да то вывод заданной строки
end.//конец блока программы
С программой, где нужно вывести последнее слово возникла проблема написать её.