С++ Напишите программу, которая играет в игру "Угадай число" следующим образом: ваша
программа "планирует" число (случайное число в диапазоне от 1 до 1000), которое т
угадать. Далее программа печатает:
У меня есть число между 1 и 1000 Отгадайте и введите ваше число ...
Далее игрок вводит первое число. Программа соответствует одной из фраз:
Прекрасно! Вы угадали число! Будете играть дальше?
Слишком мало. Попробуйте еще раз.
Слишком велико. Попробуйте еще раз.
При реализации игры необходимо написать функцию, которая принимает два числа:
"Задуманное" и ответ игрока, а после анализа печатать одну из фраз.
Вот код но мне нужно с функции переделать.
#include
#include
#include
#include
#include
using namespace std;
void main()
{
setlocale(LC_CTYPE, "ukr");
srand(unsigned(time(NULL)));
int a, b, i;
a = rand() % 1000 + 1;
printf( "Гра \"Вгадай число\".\n\n");
printf( "У мене є число між 1 та 1000.\n");
printf( "Відгадайте і введіть ваше число\n\n");
for (i = 1; i < 100; i++)
{
printf( "--->");
scanf_s("%d",&b);
if (b == a)
{
printf("Чудово! Ви вгадали число! Будете грати далі?\n");
printf("Ви вгадали число з %d попитки!\n",i);
break;
}
if (b > a)
{
printf("Занадто велике. Спробуйте ще раз.\n");
}
if (b < a)
{
printf("Занадто мале. Спробуйте ще раз.\n");
}
}
if (b != a && i == 100)
{
printf("Нажаль ви так і не вгадали число ");
printf("\n");
}
}

superakkroyale2 superakkroyale2    3   15.06.2021 13:15    0

Другие вопросы по теме Информатика