С. написать программу для : пользователь вводит с клавиатуры величину, выраженную в килобайтах. программа переводит ее в биты и мегабайты. в паскале

AnastasiaHCWP AnastasiaHCWP    1   20.03.2019 10:39    33

Ответы
dsfsksgsms dsfsksgsms  26.05.2020 07:36

var x: real;

begin

writeln('Введите число(Кб): ');

readln(x);

writeln(x,' Кб = ',x*1024*8,' бит');

writeln(x,' Кб = ',x*1024,' байт');

writeln(x,' Кб = ',x/1024,' Мб');

end.

ПОКАЗАТЬ ОТВЕТЫ
zdacieva07 zdacieva07  26.05.2020 07:36

program line_4;

uses crt;

var

kb, b: longint;

mb: real;

begin

clrscr;

write(‘kb (килобайт) = ‘); readln(kb);

b:=kb*1024*8;

mb:=kb/1024;

writeln(kb,‘ килобайт = ‘, b, ‘ бит = ‘, mb:6:4, ‘ мб’);

readkey;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика