С клавиатуры вводится трехзначное число. Написать программу которая определяет какая цифра числа минимальная Напишите в паскале.

esya14 esya14    3   13.02.2021 05:27    3

Ответы
Maksim3131 Maksim3131  15.03.2021 06:00

program z1;

var a,m:integer;

begin

write('Введите трёхзначное число: ');

readln(a);

m:=a mod 10;

if a div 100 < m then m:=a div 100;

if a div 10 mod 10 < m then m:=a div 10 mod 10;

write('Минимальная цифра числа: ',m)

end.

Объяснение:

div - результат целочисленного деления

mod - остаток от целочисленного деления  

Вводим число

Присваиваем переменной m значение последней цифры числа

Сравниваем переменную m  с первой цифрой числа, если первая цифра числа меньше переменной m, то присваиваем переменной m значение первой цифры числа

Сравниваем переменную m  со второй цифрой числа, если вторая цифра числа меньше переменной m, то присваиваем переменной m значение второй цифры числа

Выводим переменную m

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика