с информатикой
Практическая работа
Линейные программы. Арифметические выражения
Задание 1. Даны x, y, z. Написать программу для вычисления a
hello_html_266d9dc3.gif
Этапы выполнения задания
I Определение исходных данных: переменные x, y, z.
II Определение результатов: переменная a.
III Алгоритм решения задачи.
1 Ввод исходных данных
2 Вычисление значения выражения
3 Вывод результата.
IV Описание переменных:
Все переменные, определенные для решения задачи, имеют тип real. (Переменные x, y, z могут быть и целого типа, а переменная а только вещественного типа, поскольку в выражении используется операция деления.)
V Программа:
program Prim_1
Var x,y,z,a: real;
Begin
Write(‘введите значение x=’);
Readln(x);
Write(‘введите значение y=’);
Readln(y);
Write(‘введите значение z=’);
Readln(z);
a:=(2*x+3*y-z)/(3+2*x);
Writeln(‘a=’,a:7:3);
End.
VI Тестирование программы:
1. Запустите программу и введите значения
x=3
y=2
z=0
Проверьте, результат должен быть следующим:
a= 1.333
Проверить правильность вычислений можно на калькуляторе.
2. Заполните таблицу
x
y
z
a
1.
2
-5
1
2.
2.362
4.258
-7.458
3.
-1.2358
-4.554
5.562
3. Подберите такие значения x, y, z, чтобы значение а= 2.000
4. Что изменится и почему, если в программе заменить команду Writeln(‘a=’,a:7:3); на команду Writeln(a);?
5. Как распечатать только целую часть результата?
Примечание. Тип real предназначен для переменных вещественного типа. Переменные данного типа выводятся на экран монитора с большим дробным хвостом. Во избежание этого можно указать количество цифр выводимых вообще и после запятой (дробной части). Например, Writeln(‘a=’,a:5:2) - первая цифра 5 обозначает количество мест выделенных для цифр всего числа, вторая 2 - цифры дробной части. Точка тоже захватывается в количество мест для всего числа (т.е. в 5, в данном случае).
Задание 2. Даны x, y, z. Написать программу для вычисления b.
hello_html_3bacba08.gif
Тестирование программы:
1. Запустите программу и введите значения
x=9
y=-7
Проверьте, результат должен быть следующим:
a= 1.000
Проверить правильность вычислений можно на калькуляторе.
2. Заполните таблицу:
x
y
b
1
16
-5
2
2.362
4.258
3
-1.2358
-4.554
Задание 3. Составить программу вычисления значения выражения:
hello_html_m14161d4a.png
Заполните таблицу:
a
b
c
y
1
2,23
4,48
-2,5
2