с информатикой 10 класс 1. В программе используется одномерный целочисленный массив А с индексами от 0 до 9. Значения элементов равны 1, 12, 23, 34, 45, 56, 67, 78, 89, 90, то есть А[0]=1, А[1]=12 и т. д. Определите значение переменной S после выполнения следующего фрагмента программы:
s:=5;
n:=10;
For I:=1 to n-1 do begin
s:=s+A[i]×A[i]-A[i-1]×A[i-1];
end;

2. В программе используется одномерный целочисленный массив А с индексами от 0 до 9. Значения элементов равны 5, 7, 2, 3, 4, 6, 5, 5, 6, 4, то есть А[0]=5, А[1]=7 и т. д. Определите значение переменной S после выполнения следующего фрагмента программы:
s:=0;
For i:=0 to 8 do begin
If A[i] < A[9] then begin
t:=A[i];
A[i]:=A[8-i];
A[8-i]:=t;
s:=s+t;
End
End

3. В программе используется одномерный целочисленный массив А с индексами от 0 до 9. Значения элементов равны 12, 8, 15, 23, 11, 4, 9, 22, 10, 15 соответственно, то есть А[0]=12, А[1]=8 и т.д. Определите значение переменной S после выполнения следующего фрагмента программы:
s:=0;
n:=7;
for i:=0 to 9 do
If A[i] <= А[n] then begin
s:=s+A[i];
t:=A[i];
A[n]:=A[i];
A[n]:=t;
n:=i mod 3;
End
Writeln(s);

skawin2017 skawin2017    3   29.03.2021 00:26    2

Другие вопросы по теме Информатика