с Информатикой.
1)Задан массив X=[2, 4, 1,0,8,5], чему равно значение S после выполнения фрагмента программы?
S:= 0;
for k:=1 to N do begin
if x[k]>3 then
S:= S + X[k]
end;
2)Оператор:
for i:=1 to 20 do
if a[i]<>0 then writeln (a[i]);
выводит на экран:
Выберите один ответ:
a. цифру 0
b. положительные элементы массива а
c. ненулевые элементы массива а
d. отрицательные элементы массива а
3)Задан массив X[1..N] и фрагмент программы. Что вычисляет данная программа?
M:= X[1];
for k:=2 to N do begin
if x[k]>m then
M:= X[k]
end;
Выберите один ответ:
a. количество элементов массива, равных М
b. минимальное значение элементов массива
c. элемент массива, равный М
d. максимальное значение элементов массива
4)Задан массив X[1..N] и фрагмент программы обработки его. Что находит данный фрагмент программы?
S:= 0;
for k:=1 to N do begin
if x[i] mod 2=0 then
S:= S + 1
end;
Выберите один ответ:
a. Количество нечетных элементов массива
b. Количество четных элементов массива
c. Количество нулевых элементов массива
d. Сумму четных элементов массива
5)Выберите правильные варианты вывода элементов массива на печать в столбик (каждый элемент на новой строке).
Выберите один или несколько ответов:
a. for i:=1 to n do writeln(` a`,i,`=`,a[i]);
b. for i:=1 to n do write(a[i]);
c. for i:=1 to n do writeln(i);
d. for i:=1 to n do writeln(a[i]);
6)Задан массив X[1..N]. Какой оператор надо поставить вместо многоточия, чтобы найти в переменной S сумму всех элементов массива? Вводите ответ без пробелов.
S:= 0;
for k:=1 to N do begin
...
end;