Решить в питоне (python) 11 !
надо написать программу, которая принимает текст и выводит два слова слова: наиболее часто встречающееся слова и самое длинное слово.

буду .

gadjimira gadjimira    1   30.10.2019 09:41    38

Ответы
GayaneshkaBrainly GayaneshkaBrainly  17.08.2020 11:53

n = input()

n=n.replace("."," ")

n=n.replace(","," ")

n=n.replace("!"," ")

n=n.replace("?"," ")

n=n.replace("-"," ")

n=n.replace("("," ")

n=n.replace(")"," ")

n = n.split()

maxlength = ""

maxcount  = ""

for a in range(len(n)):

   if len(n[a])>len(maxlength):

       maxlength = n[a]

   if n.count(n[a])>len(maxcount):

       maxcount = n[a]

 

print("maxcount: "+maxcount)

print("maxlength: "+maxlength)

Объяснение:

есть нюанс:а что если 2 или больше слова которые может быть одинаково длиной какую должен выводит?

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика