Решить в паскале с использованием цикла с ! составить программу запроса пароля пока не будет введён пароль верно. в программе предусмотреть счётчик неправильных вводов пароля.

milyukovnikita milyukovnikita    3   17.03.2019 23:25    33

Ответы
qwerty665 qwerty665  25.05.2020 21:57

var

 parole, s: string;

 Count: byte;

begin

 parole := 'Земля прощай. В добрый путь!';

 Count := 0;

 

 repeat

   Writeln('Введите пароль');

   Readln(s);

   Count += 1

 until (s = parole) or (Count = 3);

 

 if Count = 3 then

 begin

   Write('Вы не индентификацию. Доступ закрыт');

   Halt

 end

 else

   Write('Доступ разрешен.')

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика