Решить в паскале : написать программу решения квадратного уравнения

совуша2007 совуша2007    2   15.08.2019 06:40    0

Ответы
mrnaruto004ovx0o3 mrnaruto004ovx0o3  04.10.2020 20:31
Program QuadraticEquation;
  Var a, b, c, d, x1, x2:real;
Begin
      Writeln('vvedite a, b, c');
      Readln(a,b,c);
      If A=0 then
           Writeln('algoritm ne primenim');
      D:=b*b-4*a*c;
      If D<0 then
           Writeln('deystvit resheniy net');
      If D=0 then
           Begin
                  x1:=-b/(2*a);
                  Writeln('x1=',x1);
           End
      Else
           Begin
                  x1:=(-b+sqrt(D))/(2*a);
                  x2:=(-b-sqrt(D))/(2*a);
                  Writeln('x1=',x1, 'x2=', x2);
           End;
end.
               Держи!)
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика