Решить , учитель бьется цветочком! составьте программу вычисления количества трехзначных чисел-палиндромов(чисел, которые читаются одинаково слева направо и справа налево).
Uses crt; var e,d,s,i,k:integer; begin k:=0; for i:=100 to 999 do begin e:=i mod 10; d:=(i div 10)mod 10; s:=i div 100; if (e=s) or ((e=d) and (e=s)) then inc(k); end; writeln(k); end.
var e,d,s,i,k:integer;
begin
k:=0;
for i:=100 to 999 do
begin
e:=i mod 10;
d:=(i div 10)mod 10;
s:=i div 100;
if (e=s) or ((e=d) and (e=s)) then inc(k);
end;
writeln(k);
end.