Решить по информатике) нужно написать программу на паскале. тема: циклы вот условие) как известно, национальным овощем жителей сказочной страны мурландии является картофель. новое руководство тем, чтобы был сформированы запасы этого ценнейшего продукта на зиму. в этом году был хороший урожай картофеля и n домов со всей мурландии внесли свою лепту в общее хранилище. поставлен план получить не менее k тонн. из каждого дома этой сказочной страны сдали по аi тонн картофеля. можно ли получить k или более тонн картофеля и выполнить план? входные данные: в первой строке входного файла натуральные числа n и k, в последующих n строках содержатся количество тонн картофеля из каждого дома. ограничения: n, k, ai - натуральные числа, не превосходящие 20 000. выходные данные: в единственную строку выходного файла вывести yes в случае ответа "да", no в противном случае.
tmp,s,i,k,n:integer;
f,w:text;
begin
Assign(f,'input.txt');reset(f);
Assign(w,'output.txt');rewrite(w);
Readln(f,n,k);
for i:= 1 to n do
begin
readln(f,tmp);
s:=s+tmp;
end;
if s >=k then Writeln(w,'Yes')
else Writeln(w,'No');
close(f);close(w);
end.