Решить по икт. 39. составьте программу вычисления длины боковой стороны равнобедренного треугольника, у которого площадь равна s, а длина основания в три раза больше длины высоты, опущенной на него.

Irinazpopo Irinazpopo    3   10.09.2019 21:20    4

Ответы
lera5053 lera5053  07.10.2020 06:07
Площадь треугольника - s = a*h/2
a = 3*h ⇒ s = 3*h*h/2 ⇒ h = √(2*s/3)
Искомая боковая сторона треугольника - это гипотенуза треугольника со сторонами a/2 (=3*h/2)  и h ⇒ b^2 = (3*h/2)^2+h^2

var s,b,h:real;
begin
readln(s);
h:=sqrt(2*s/3); //s:=3*h*h/2
b:=sqrt(13)*h/2; // b^2 =(3*h/2)^2+h^2
writeln('a = ',3*h:5:2,' h = ',h:5:2);
writeln('b = ',b:5:2);
end.

Пример:
16
a = 9.80 h = 3.27
b = 5.89
ПОКАЗАТЬ ОТВЕТЫ
Tamalova5 Tamalova5  07.10.2020 06:07
На PascalABC.
(20 символов аиыоалокуаикуцлокиуцоауц)
Решить по икт. 39. составьте программу вычисления длины боковой стороны равнобедренного треугольника
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика