Решить. напишите программу формирования массива размером 5х5 с датчика случайных чисел замените в нем значения элементов с четной суммой индексов на значение второго элемента массива из первой строки. выведите на экран исходный и измененный массив. (паскаль абс) с объяснением

настя7567 настя7567    2   11.08.2019 19:30    4

Ответы
nelia3232 nelia3232  08.09.2020 12:50
Const
n=5;
var
a:array[1..n,1..n] of integer;
i,j:integer;

begin
//генератор случайных чисел. Диапазон от 1 до 10.
 for i:=1 to n do
  begin
  for j:=1 to n do
   begin
    a[i,j]:=random(10)+1;
    write(a[i,j]," ");
   end;
   writeln();
  end;

//Проверка условия и переприсвоение, если верно.
 for i:=1 to n do
  for j:=1 to n do
   begin
    if (((i+j) mod 2)=0) then
     a[i,j]:=a[1,2];
   end; 
 
//Вывод полученного массива.
  for i:=1 to n do
  begin
  for j:=1 to n do
   begin
    write(a[i,j]," ");
   end;
   writeln();
  end;

//Ожидание.
readln();
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика