Решить: напишите программу для решения следующей . камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо неё автомобилей, округляя значения скорости до целых чисел. необходимо определить максимальную зарегистрированную скорость автомобиля. если скорость хотя бы одного
автомобиля была меньше 30 км/ч, выведите "yes", иначе выведите "no".программа получает на вход число проехавших автомобилей n(1< n< 30), затем указываются их скорости. значение скорости не может быть меньше 1 и больше 300. программа должна сначала вывести максимальную скорость затем yes или
no. ! пример вводных данных474696366примеры входных данных74no​

irhev73fa irhev73fa    2   07.10.2019 15:30    56

Ответы
trjg456isa trjg456isa  10.10.2020 01:57

n = int(input())

max_speed = 0

check = True

for i in range(0, n):

   a = int(round(float(input(

   if a > max_speed:

       max_speed = a

   if check == True:

       if a < 30:

           check = False

print(max_speed)

if not check:

   print('YES')

else:

   print('NO')

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика