Решить на языке Питон 3! Неспокойно сейчас на стапелях шестого дока межгалактического порта планеты Торна. Всего через месяц закончится реконструкция малого броненесущего корвета ’Эния’. И снова этому боевому кораблю и его доблестной команде предстоят тяжелые бои за контроль над плутониевыми рудниками Сибелиуса. Работа не прекращается ни на секунду, лазерные сварочные аппараты работают круглые сутки. От непрерывной работы плавятся шарниры роботов-ремонтников. Но задержаться нельзя ни на секунду. И вот в этой суматохе обнаруживается, что термозащитные панели корвета вновь требуют обработки сульфидом тория. Известно, что на обработку одного квадратного метра панели требуется 1 нанограмм сульфида. Всего необходимо обработать N прямоугольных панелей размером A на B метров. Вам необходимо как можно скорее подсчитать, сколько всего сульфида необходимо на обработку всех панелей ’Энии’. И не забудьте, что панели требуют обработки с обеих сторон. Формат ввода Содержится 3 целых положительных числа N,A,B .N(N≤100), A(A≤100), B(B≤100). Формат вывода Вывести единственное число - вес необходимого для обработки сульфида тория в нанограммах.

апролдпролорпаквнквк апролдпролорпаквнквк    1   09.09.2020 01:24    116

Ответы
mihaill1988 mihaill1988  15.10.2020 19:09

var

f,g: text;

n,a,b,s: integer;

begin

assign(f,'input.txt');

reset(f);

read(f,n); read(f,a); read(f,b);

close(f);

assign(g,'output.txt');

rewrite(g);

s:=n*a*b*2;

write(g,s);

close(g);

writeln('Èñêîìûå äàííûå çàïèñàíû â ôàéë "output.txt"');

readln;

end.

0

Объяснение:

Если необходимо проводить проверку на существование файла - она в разных паскалях проводится по разному.

А эта задача решается очень просто - произведение n, a, b умножается еще и на 2.

ПОКАЗАТЬ ОТВЕТЫ
juliati88tan juliati88tan  08.01.2024 16:54
Добрый день! Давайте начнем с того, что мы должны подсчитать количество сульфида тория, необходимого для обработки всех панелей корвета 'Эния'. Нам даны три числа: N, A и B, где N - количество панелей, A - длина панели в метрах, а B - ширина панели в метрах.

Для того чтобы решить эту задачу, нам необходимо узнать общую площадь всех панелей. Общая площадь будет равна произведению количества панелей на площадь одной панели. Площадь одной панели будет равна произведению длины и ширины панели.

Теперь давайте напишем программу на языке Python 3 для решения этой задачи:

```python
# Ввод данных
N, A, B = map(int, input().split())

# Вычисление площади одной панели
panel_area = A * B

# Вычисление общей площади всех панелей
total_area = N * panel_area

# Вычисление необходимого количества сульфида тория в нанограммах
sulfide_weight = total_area

# Вывод результата
print(sulfide_weight)
```

Давайте рассмотрим пример ввода и соответствующий ему вывод:

Пример 1:
Ввод: 3 2 4
Вывод: 24

Рассчитаем, почему ответ будет равен 24:
Количество панелей (N) = 3
Длина панели (A) = 2 метра
Ширина панели (B) = 4 метра

Площадь одной панели: 2 * 4 = 8 квадратных метров
Общая площадь всех панелей: 3 * 8 = 24 квадратных метров

Так как на обработку 1 квадратного метра панели требуется 1 нанограмм сульфида тория, то на обработку всех панелей потребуется 24 нанограмма сульфида тория.

Надеюсь, этот ответ понятен для вас. Если у вас возникнут еще вопросы, не стесняйтесь задавать. Я всегда готов помочь вам!
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика