Решить кто знает паскаль вот дан файл с оценками .txt учащихся написать программу которая определяет количество пятерок, четвёрок, троек. вывести их количество на экран. нужно написать в текстовом документе а с паскаля это прочитать
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016 begin var a:=ReadallLines('in.txt')[0].ToIntegers; Writeln('Исходный набор отметок'); a.Println; var k3:=a.Where(x->x=3).Count; var k4:=a.Where(x->x=4).Count; var k5:=a.Where(x->x=5).Count; Writeln('Троек- ',k3,', четверок- ',k4,', пятерок-',k5) end.
begin
var a:=ReadallLines('in.txt')[0].ToIntegers;
Writeln('Исходный набор отметок'); a.Println;
var k3:=a.Where(x->x=3).Count;
var k4:=a.Where(x->x=4).Count;
var k5:=a.Where(x->x=5).Count;
Writeln('Троек- ',k3,', четверок- ',k4,', пятерок-',k5)
end.
Тестовое решение
Исходный набор отметок
3 4 4 5 5 3 4 4 5 4 3 5 5 3 5 3 4 3 3 4 5 4 4 3 4 4 3 4 5 4
Троек- 9, четверок- 13, пятерок-8
Файл с отметками in.txt дан во вложении.