Решить хотя бы 1-2
2. Напишите программу, которая в последовательности натуральных чисел определяет
количество чисел, кратных 2 и не оканчивающихся на 0. Программа получает на вход целые
числа, количество введённых чисел неизвестно, последовательность чисел заканчивается
числом 0 (0 – признак окончания ввода, не входит в последовательность).
В последовательности всегда имеется число, удовлетворяющее условию
Программа должна вывести одно число: количество чисел, кратных 2 и не оканчивающихся на 0.

3. Напишите программу, которая в последовательности натуральных чисел определяет
произведение чисел, кратных 3 и оканчивающихся на 3. Программа получает на вход целые
числа, количество введённых чисел неизвестно, последовательность чисел заканчивается
числом 0 (0 – признак окончания ввода, не входит в последовательность).
В последовательности всегда имеется число, удовлетворяющее условию
Программа должна вывести одно число: произведение чисел, кратных 3 и оканчивающихся на 3.

4. Напишите программу, которая в последовательности натуральных чисел находит среднее
арифметическое чисел, кратных 4, или сообщает, что таких чисел нет (выводит NO).
Программа получает на вход натуральные числа, количество введённых чисел неизвестно,
последовательность чисел заканчивается числом 0 (0 признак окончания ввода, не входит
в последовательность).
Количество чисел не превышает 100. Введённые числа не превышают 300.
Программа должна вывести среднее арифметическое чисел, кратных 4 или вывести «NO»,
если таких чисел нет

seydchubra seydchubra    2   14.04.2020 12:27    5

Ответы
lubas143 lubas143  14.04.2020 12:30

Program M1;

var s,x:integer;

begin

s:=0;

x:=1;

while x<>0 do

begin

read(x);

if (x mod 7=0) and (i mod 10=0) then s:=x+s;

end;

writeln(summa=,s);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика