Решить . 1.сформулируйте и выведите на экран массив из девяти элементов, каждые три последовательных элемента которого составлены по следующему правилу: 1-й равен случайному двузначному числу; 2-й равен целой части от деления случайного трехзначного числа на его индекс; 3-й равен остатку от деления случайного двузначного числа на 10. 2.напишите программу формирования и вывода массива произвольного размера так, чтобы каждый последующий элемент, начиная с третьего, был равен разности двух предыдущих элементов, увеличенной на номер строки текушего элемента. два первых элемента задайте с клавиатуры. заранее )

Aslihaaan Aslihaaan    3   04.06.2019 19:20    1

Ответы
OctavisicStar691 OctavisicStar691  01.10.2020 19:19
1) Program p1;
Uses crt;
Var A: array [1..9] of integer;
i: integer;
Begin clrscr;
for i:=1 to 9 do
begin
case i of
1,4,7: a[i]:= random (99-10+1)+10;
2,5,8: (random (999-100+1)+100) div i;
3,6,9: (random (99-10+1)+10) mod 10;
end;
write (a[i],' ');
end;
readln;
readkey;
end.

2) Program p2;
Uses crt;
Var A: array [1..15] of integer;
i: integer;
Begin clrscr;
Writeln ('Введите первые 2 элемента массива');
Read (a[1],a[2]);
for i:=3 to 15 do
begin
a[i]:=(a[i-1]-a[i-2])+i;
write (a[i],' ');
end;
readln;
readkey;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика