Python, задача

Сегодня утром жюри решило добавить в вариант еще одну задачу. Очень Легкую Задачу. ответственный секретарь Оргкомитета напечатал ее условие в одном экземпляре, и теперь ему до начала олимпиады надо напечатать еще N копий.

В его распоряжении два ксерокса. Первый копирует лист за x секунд, а второй - за y. Можно использовать один ксерокс, а можно два (и даже одновременно, так как копировать можно не только с оригинала, но и с копии ему выяснить какое минимальное время ему понадобится.

Формат ввода

Вводятся три числа: N, x, y.

Формат вывода

Выведите одно число - минимальное количество секунд, которое нужно на создание N копий.

Примеры

Ввод 4 1 1
Вывод 3

Ввод 5 1 2
Вывод 4

katya99972011 katya99972011    3   09.04.2020 13:25    24

Ответы
He1111p He1111p  12.10.2020 23:57

N, x, y = map(int, input().split())

x_time, y_time = x, y

time = 0

if x > y:

   time += y

else:

   time += x

N -= 1

while N > 0:

   if x_time == y_time:

       N -= 2

       time += x

       y_time, x_time = y, x

   elif x < y:

       if x_time < y:

           x_time += x

           N -= 1

           time += x

   else:

       if y_time < x:

           y_time += y

           N -= 1

           time += y

print(time)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика