(Python) Вам нужно написать программу, которая за ввести оценки для четырёх учеников: Bill, Jane, John, Mary. В конце необходимо вывести среднюю оценку для всей группы, округлённую в большую сторону. Предполагайте, что пользователь вводит только числа в оценки. Средняя оценка вычисляется как среднее арифметическое - сумма всех оценок, делённая на количество учеников.
Что должно присутствовать в коде программы:

Каждую оценку нужно сохранять в словаре marks. В качестве ключей использовать имена учеников.
Для подсчёта суммы обращаться к каждой записи в словаре по ключу.

Умники121212 Умники121212    2   28.03.2020 15:12    6

Ответы
grange grange  12.10.2020 08:08

marks = {'Bill': int(input()), 'Jane': int(input()), 'John': int(input()), 'Mary': int(input())}

average = 0

for key in marks.keys():

   average += marks[key]

print(round(average / 4))

'округлённую в большую сторону'

Если нужно округлять всегда в большую сторону(то есть из 4.1 выводить среднюю 5), то в начале программы пишешь:

import math

, а в конце вместо 'print(round(average / 4))', пишешь:

print(math.ceil(average / 4))

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика