Программист получил задание написать программу, которая будет выводить на экран количество таких разрядов числа, в которых стоят четные цифры. Программист торопился и допустил ошибки в программе Вот, что у него получилось:
Паскаль
var K, d, s: longint;
begin
readln(K);
s := 1;
while K > 0 do
begin
d := K mod 10;
if dig mod 2 = 0 then
s := s + d;
K := K div 10;
end;
writeln(s)
end.
Последовательно выполните следующее.
1. Напишите, что выведет эта программа при вводе числа 182.
2. Приведите пример такого трёхзначного числа, при вводе которого программа выдаёт верный ответ.
3. Найдите и исправьте все ошибки в этой программе (их может быть одна или несколько). При этом ошибка затрагивает только одну строку ее можно исправить, не меняя другие строки. Для каждой ошибки:
1) выпишите строку, в которой сделана ошибка;
2) укажите, как исправить ошибку, т.е. приведите правильный вариант строки.
Обратите внимание, что требуется найти ошибки в имеющейся программе, а не написать свою, возможно, использующую другой алгоритм решения. Исправление ошибки должно затрагивать только строку, в которой находится ошибка.