Программирование в си++ ! нужно написать программу, в которой 2 переменные типа float в main() являются локальными, а после используются в функции, которая вычисляет квадраты этих чисел. , исправьте мои ошибки. #include #include #include #include int function(float *pointer1, float *pointer2) { float ch1, ch2; ch1 = powf(*pointer1, 2); ch2 = powf(*pointer2, 2); printf_s("квадрат первого числа равен: %f\n", ch1); printf_s("квадрат второго числа равен: %f\n", ch2); system("pause"); return(0); } int main() { setlocale(lc_all, "rus"); float a, b; float *pointer1; float *pointer2; printf_s("введите первое число: "); scanf_s("%f", & a); printf_s("введите второе число: "); scanf_s("%f", & b); pointer1 = & a; pointer2 = & b; function(& a,& b); } + напишите программу с возвратом значений
#include <iostream>
#include <cmath>
using namespace std;
int function(float *pointer1, float *pointer2)
{
float ch1, ch2;
ch1 = powf(*pointer1, 2);
ch2 = powf(*pointer2, 2);
cout<<"Квадрат первого числа равен:"<<ch1<<endl;
cout<<"Квадрат второго числа равен:"<<ch2<<endl;
return(0);
}
int main()
{
setlocale(LC_ALL, "RUS");
float a, b;
float *pointer1;
float *pointer2;
cout<<"Введите первое число:";
cin>>a;
cout<<"Введите второе число:";
cin>>b;
pointer1 = &a;
pointer2 = &b;
function(&a,&b);
system("PAUSE");
}