Программа получает на вход количество чисел в последовательности, а затем сами числа. количество чисел не превышает 1000. введённые числа по модулью не превышают 30 000. программа должна вывести одно число: сумму чисел, кратных 7 и оканчивающихся на 4.

ChristenChy ChristenChy    3   07.09.2019 22:00    1

Ответы
knarik88 knarik88  06.10.2020 23:42
//PascalABC.NET
var
    s : integer;
begin
    var n := ReadlnInteger('Сколько будет чисел? ');
    writeln('Вводите числа');
    var a := ReadArrInteger(n);
    for var i:=0 to n-1 do
        if (a[i] mod 10 = 4) and
            (a[i] mod 7 = 0) then
            s := s + a[i];
    writeln('Сумма чисел равна ', s)
end.

Программа получает на вход количество чисел в последовательности, а затем сами числа. количество чис
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика