tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Программа перевода из 10
Программа перевода из 10 сс в 16 сс на паскале. (как можно проще, используя функции, заранее .
Kylie15
3 29.05.2019 22:40
2
Ответы
Khmelnitskaya
29.06.2020 12:49
Var
d, n: longint;
h: string;
begin
write('n? ');
readln(n);
repeat
d := n mod 16;
if d < 10 then
h := chr(ord('0') + d) + h
else
h := chr(ord('A') - 10 + d) + h;
n := n div 16;
until n = 0;
writeln(h, 'h');
end
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
malaxov04
27.10.2020 07:48
Составьте программу рисования слоненка...
ahahahahahhahah
27.10.2020 07:48
5. Соотнеси типы вирусов с их описанием 1 Загрузочные вирусы А Атакуют документы, в которых могут вставляться макрокоманды 2 Файловые вирусы В Распространяются по компьютерной...
dilovardustiev1
27.10.2020 07:49
Процессордің разрядтылығы нені анықтайды: керек...
Soechatko
27.10.2020 07:49
Создайте базу данных «Мои друзья» с использованием следую щих типов полей: текстовое, числовое, дата/время, логическое...
nataalferova8
27.10.2020 07:49
5. Вирусы могут заразить файлы: (выбрать 3 правильных ответа) * рисунки – * gif, *.jpg командные файлы — *.bat любые данные (без программного кода) библиотеки – * dll документы...
DrSteklis
27.10.2020 07:52
Составить программу для рисования медвежонка...
bessmertny69
27.10.2020 08:04
Современная эргономика что это такое...
egorkarevyakin
27.10.2020 08:04
Закодируйте слово БАНТ, если известно, что в таблице ASCII А=128, Б=129, В=130, …. Т=146...
hdn12
27.10.2020 08:04
1.Не себепті ойын жасау барысында сценарий құрамыз?...
Vad1mm
27.10.2020 08:04
3. Раскодируй слово: 01010111 01001111 01010010 01001011...
Популярные вопросы
Розв’язати рівняння за до дискрімінанту: ( 3 завдання, 1 варіант)...
1
Напишите Сочинение на тему А. Алексина « О зависти» Алгоритм написания сочинения...
2
1) Графически выделите в тексте диктанта обособленные члены предложения.Акимов,...
2
Четверо молодых людей наловили в заповедном озерке рыбу, развели костер (как...
3
Особливости повединки ставленя до людей ддо пради до того го оточуйе це...
1
К 10 мл анализируемого раствора К2Сr2О7 , подкисленного серной ки- слотой,...
3
Меня стало плохо слышно в дискорде что делать?...
2
1. Как идейно соотносятся эти легенды израссказа «Старуха Изергиль»?2. Чем...
2
Астронавт потерпел аварию-у ракеты поломалась конусообразная...
3
Назовите страны, зашифрованные на карте цифрами, опишите особенности взаимоотношений...
1
d, n: longint;
h: string;
begin
write('n? ');
readln(n);
repeat
d := n mod 16;
if d < 10 then
h := chr(ord('0') + d) + h
else
h := chr(ord('A') - 10 + d) + h;
n := n div 16;
until n = 0;
writeln(h, 'h');
end