Программа паскаль напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). входные данные входная строка содержит одно натуральное число. выходные данные программа должна вывести слово 'yes', если в числе есть две одинаковые цифры, стоящие рядом, и слово 'no', если такой пары цифр нет.

iskanderkhusano iskanderkhusano    3   27.06.2019 06:00    1

Ответы
sonua3 sonua3  02.10.2020 12:54
Var
s:string;
i:longint;
t:boolean;

begin
read(s);
t:=false;

for i:=1 to length(s)-1 do
 if s[i]=s[i+1] then t:=true;

if t then writeln('YES') else writeln('NO');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика