Программа на с++.составить программу для проверки утверждения: "результатом вычисления значения выражения x^2+x+41 при x=(0,40), являются простые числа."

andrei271 andrei271    1   06.08.2019 10:50    2

Ответы
1Raffaelka1 1Raffaelka1  04.10.2020 00:55
#include <stdio.h>

#define left 0
#define right 40

int prime(int x){
  int d = 2;
  while(d < x && x%d != 0) d++;
  return d == x;    
}

int main(){
  int x;
  for(x = left; x <= right; x++)
      if( !prime(x*x + x + 41) ){
          printf("False \n%d^2 + %d + 41 = %d \n", x, x, x*x + x + 41);
          break;
      }
  if(x > right) printf("True \n");
  return 0;    
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика