Программа на с++ напишите программу, которая вводит четыре натуральных числа (a, b, c и d) и находит все пятизначные числа, которые при делении на a в остатке b , а при делении на c в остатке d . входные данные первая входная строка содержит два натуральных числа, разделённые пробелами: a и b. вторая строка содержит натуральные числа c и d, также разделённые пробелом. гарантируется, что 0 ≤ b ≤ a и 0 ≤ d ≤ c. выходные данные программа должна вывести в одну строчку через пробел все пятизначные натуральные числа, которые при делении на a в остатке b, а при делении на c в остатке d . если таких чисел нет, программа должна вывести число -1.

sp14 sp14    3   08.09.2019 01:00    19

Ответы
Ксения203 Ксения203  06.10.2020 23:55
#include <iostream>
using namespace std;

int main(){
int a,b,c,d,o=0;
cin>>a>>b>>c>>d;
for (int i=10000; i<=99999;i++)
  if (i % a ==b && i % c == d)
  {
        cout<<i<<' ';
  o=1;
  }
if (o==0)
    cout<<-1;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика