Практическая работа №23. сумма значений элементов массива уровень a. напишите программу, которая заполняет массив из 10 элементов случайными чис-лами на отрезке [–5; 5] и находит сумму ненулевых элементов. уровень b. напишите программу, которая заполняет массив из 10 элементов случайными чис-лами на отрезке [–2; 2] и находит произведение ненулевых элементов. уровень c. напишите программу, которая заполняет массив из 20 элементов случайными чис-лами на отрезке [100; 1000] и находит отдельно сумму элементов в первой и во вто-рой половинах массива

ятупик2 ятупик2    3   05.10.2019 20:10    12

Ответы
MN0G0ZNAAL MN0G0ZNAAL  09.10.2020 22:22

#1


var

mas : array [1..10] of integer;

sum : integer := 0;

begin

for var i:=1 to 10 do begin

mas[i] := random(-5,5);

if (mas[i] <> 0) then

sum += mas[i];

end;

writeln(sum);

end.



#2



var

mas : array [1..10] of integer;

sum : integer := 1;

begin

for var i:=1 to 10 do begin

mas[i] := random(-2,2);

if (mas[i] <> 0) then

sum *= mas[i];

end;

writeln(sum);

end.

#3


var

mas : array [1..20] of integer;

sum : integer := 0;

sum1 : integer := 0;

begin

for var i:=1 to 20 do begin

mas[i] := random(100,1000);

if (i < 11) then sum += mas[i];

if (i >= 11) then sum1 += mas[i];

end;

writeln(sum + ' ' + sum1);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика