Пользователь вводит с клавиатуры число N. Программа выводит на экран три числа:
1) сумму всех чисел на промежутке от 1 до N;
2) произведение всех нечетных чисел на промежутке от 1 до N.
3) количество чисел, которые делятся нацело на 3 на промежутке от 1 до N.
Входные данные:
Одно целое число N.
Исходные данные:
Вывести три числа: 1) сумму всех чисел;
2) произведение нечетных чисел;
3) количество чисел, которые делятся на 3

lagis9 lagis9    3   20.12.2020 18:25    2

Ответы
hhgfg hhgfg  19.01.2021 18:25

N = int(input())

sums = 0

pr = 1

counter = 0

for i in range(1,N+1):

   sums += i

for i in range(1,N+1,2):

   pr *= i

for i in range(1,N+1):

   if i % 3 == 0:

       counter += 1

print(sums)

print(pr)

print(counter)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика