Пользователь вводит 2 числа например 1 и 10 Напишите программу которая выведет все чётные числа находящиеся в этом интервале Python

зика20 зика20    2   29.11.2020 23:45    1

Ответы
alinasupieva0910 alinasupieva0910  29.12.2020 23:47

Исходный код:

a, b = map(int, input().split())  # ввод в одну строку

for i in range(a, b+1):

   if i % 2 == 0:

       print(i)

Пояснение:

Мы вводим два числа - границы диапазона. Затем перебираем все числа в этом диапазоне. Обратите внимание, я добавил 1 к b, чтобы перебор был включая число b. Если остаток числа от деления на 2 равен нулю, то число четное. Выводим его в поток вывода.

Примечание:

Соблюдайте отступы, 4 пробела или табуляция для отделения блоков циклов, ветвлений.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика