По языку программирования pascal n школьников делят k яблок “поровну”, то есть так, чтобы количество яблок, доставшихся любым двум школьникам, отличалось бы не более, чем на 1. входные данные программа получает на вход числа n и k. выходные данные программа должна вывести количество школьников, которым достанется яблок меньше, чем некоторым из их товарищей.
// Внимание! Если программа не работает, обновите версию!
Begin
var (n, k) := ReadInteger2('Введите n и k');
Writeln(k - (k div n) * n);
end.