По паскалю.условный оператор. 1.даны два действительных числа меньшее из них замените полусуммой их, а большее их произведением. 2.найдите решение уравнения ах+ в=0, если оно существует,если а=0 3.написать программу удвоения меньшего из двух чисел

koren27 koren27    1   04.06.2019 03:00    1

Ответы
Itismylife Itismylife  01.10.2020 19:09
1)
program chik2;
var a,b,c:real;
begin
readln(a,b);
if(a<b)then begin
c:=a;
a:=(a+b)/2;
b:=b*c;
end;
if(a>=b)then begin
c:=b;
b:=(a+b)/2;
a:=a*c;
end;
writeln(a,' ',b);
end.
2)
program chik;
var a,x,b:real;
begin
readln(a,b);
if(a=0)and(b<>0)then writeln('НЕТ решений');
if(a<>0)then begin
 x:=-b/a;
writeln(x);
end;
end.
3)

program chik3;
var a,b:real;
begin
readln(a,b);
if(a<b)then a:=a*2 else
if(b<a)then b:=b*2;
writeln(a,' ',b);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика