По м о г и т е, п о ж а л у й с т ! 1) вводится массив, состоящий из целых чисел. найти наибольшее среди них. входные данные сначала задано число n — количество элементов в массиве (1n35). далее через пробел записаны n чисел — элементы массива. массив состоит из целых чисел. выходные данные необходимо вывести значение наибольшего элемента в массиве. примеры входные данные 3 1 2 3 выходные данные 3 2) напишите программу, которая циклически сдвигает элементы массива вправо (например, если элементы нумеруются, начиная с нуля, то 0-й элемент становится 1-м, 1-й становится 2-м, последний становится 0-м, то есть массив {3, 5, 7, 9} превращается в массив {9, 3, 5, 7}). входные данные сначала задано число n — количество элементов в массиве (1n35). далее через пробел записаны n чисел — элементы массива. массив состоит из целых чисел. выходные данные необходимо вывести массив, полученный после сдвига элементов. примеры входные данные 6 4 5 3 4 2 3 выходные данные 3 4 5 3 4 2

minyoourae minyoourae    2   31.08.2019 12:00    7

Ответы
likamikanumberone likamikanumberone  26.04.2020 14:16
var a: array [1..100] of integer; i,  n ,  max : integer; begin writeln('rozmer'); readln(n); randomize ; if (( n>=1) and (n<=35)) then for i:=1 to n do begin a[i]:=random(90)-45 ; write(a[i]:3); end; writeln; max:=a[1] ; for i:=2 to 100 do begin if a[i]>max then max:=a[i] ; end; writeln(max); end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика