По информатике составить программу в паскале.создать одномерный массив а из 10 целых чисел (с рандома в диапазоне (-50; 100). посчитать количество отрицательных и неотрицательных элементов массива.

mar244144 mar244144    1   19.09.2019 14:50    1

Ответы
Борель Борель  08.10.2020 02:26
// PascalABC.NET 3.3
begin
  var a:=ArrRandom(10,-50,100); a.Println;
  var k:=a.Where(x->x<0).Count;
  writeln('Количество отрицательных = ',k,
          ', количество неотрицательных = ',10-k);
end.

Пример:
66 47 65 70 -3 81 45 70 -33 -31
Количество отрицательных = 3, количество неотрицательных = 7
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика