Питон. 3 задачи 2. Напишите программу, которая находит в массиве минимальный из чётных элементов и его индекс. Если в массиве нет чётных элементов, нужно вывести ответ «нет».

3. Напишите программу, которая находит в массиве максимальный элемент, десятичная запись которого оканчивается на 3, и его индекс. Если таких элементов нет, нужно вывести ответ «нет».

4. Напишите программу, которая заполняет массив из 20 элементов случайными числами на отрезке [100; 200] и находит в нём пару соседних элементов, сумма которых минимальна.

ayla678 ayla678    2   25.01.2021 18:55    101

Ответы
leonidkhadzhinov leonidkhadzhinov  25.01.2021 19:00

№2

mass = [int(s) for s in input().split()]

k = -1

for i in range(len(mass)):

   if mass[i] > 0 and mass[i] % 2 == 0:

       mn = i

       break

for j in range(len(mass)):

   if mass[j] > 0 and mass[j] % 2 == 0:

       if mass[j] < mass[mn]:

           mn = j

       k = 1

if k < 0:

   print('нет')

else:

   print(mass[mn], mn)

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика