tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Перевести в питон код
Перевести в питон код с++ #include<bits/stdc++.h>
using namespace std;
#define ll long long
#define mod 1000000007
int main()
{
ll n;
cin>>n;
ll x = 0,y = 1;
for(int i=0;i<n-1;i++)
{
ll a = x;
x = (3 * y)%mod;
y = (a + 2 * y)%mod;
}
cout<<x<<endl;
}
Rusynyk
3 14.12.2021 11:21
6
Ответы
Показать ответы (3)
Другие вопросы по теме Информатика
dasha45da
14.09.2019 02:50
Аутентификация на основе пароля, переданного по сети в открытом виде, плоха потому что не обеспечивает защиты от: a) переадресации b) перехвата c) перевода d) атак на доступность...
0004556189
14.09.2019 02:50
Водятся два натуральных числа а и в. определить: - какое из них больше, - кратно ли а числу в - принадлежат ли числа множеству двузначных чисел....
КирОаоырчлцрслчь
14.09.2019 02:50
Протокол ftp служит для: a) передачи файлов b) передачи гипертекста c) передачи сообщениями d)запуска программы с удаленного компьютера...
vavilovaev86
13.06.2019 07:40
Составьте программу, которая выводит на экран квадраты n первый натуральных чисел...
NastyDi2007
15.12.2020 10:06
Книга содержит 260 страниц. На каждой странице размещаются 46 строк, в каждой строке 35 символов. Рассчитать объём информации, содержащейся в книге, ответ записать в Мб....
DaryaGoldman1812
15.12.2020 10:07
Рассмотрите таблицу и правило условного форматирования.Перечислите адреса ячеек,которые удовлетворяютзаданному правилу.12SУспеваемость класФамили ученика Успениемост1 Айдар32...
nоname128
15.12.2020 10:07
Каким инструментом нарисован рисунок в графическом редакторе Paint? Напечатай цифру в ответе *...
stockmen
15.12.2020 10:09
1. Учёт времени Ограничение времени 1 секунда Ограничение памяти 244Mb Ввод ctiming.in Вывод ctiming.out Федя хочет сделать карьеру в компьютерной индустрии. Чтобы улучшить...
Zarina2206
15.12.2020 10:09
75%2/720.04.2020150,00 РИнфарматика...
LegoLAS09
22.05.2020 06:06
Какие идентификаторы записаны неверно? Сумма; sum; 1d, 1_d; a2; end...
Популярные вопросы
Виконати тематичну контрольну роботу у формі контрольного твору. У чому...
2
определить наибольшее значение функции с объяснением как это делать...
1
Опишите какие задачи решает шимпанзе для достижения цели...
1
5. Установіть відповідність між подією та її наслідком:1) Написання «Судебника»...
2
1) Quelles fêtes y a-t-il en hiver en France? 2) Qui est le personnage...
1
Выпишите попарно заимствованные слова с близкими по значению исконно-русскими:...
3
Выполнить превращения 1). Фосфороксид фосфора(5)фосфорная кислотафосфат...
2
Представьте в виде степени выражения (n^(-2)) ^4÷n^(-15)...
1
Рассмотрите репродукцию знаменитой картины Рембрандта Возвращение блудного...
3
Выберите лишнее слово starters-drink-main-courses-desserts...
3