tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Переведите код с qbasic
Переведите код с qbasic на pascal, : sub pq(n as long) if n then m = int(sqr(n)) print m; call pq(n - m ^ 2) end if end sub
Алина06072003
3 12.09.2019 19:10
0
Ответы
JuMpEr104
07.10.2020 10:15
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!
procedure pq(n:integer);
begin
if n<>0 then begin
var m:=Trunc(Sqrt(n));
Writeln(m);
pq(n-m*m)
end
end;
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Auebandit1337
17.09.2019 03:20
Рассчитай объём видеопамяти, необходимой для хранения графического изображения, занимающего весь экран монитора с разрешением 1024*768 и колличеством отоброжаеммых цветов,...
serob1223
17.09.2019 03:20
Написать 5-7предл эссе,чем язык программирования отличается от систем программирования...
hsjsjxn
16.08.2019 21:50
Pascalabc.net дана двумерная матрица a(n,m). удалить все столбцы,в которых первый элемент больше последнего ( сесия! )...
25409
14.06.2019 18:30
Текст 100 страниц на странице 64 строки по 32 символа , алфавит включает в себя кириллицу и латиницу прописную и строчную, 10 цифр и 15 различных символов определить информационный...
roksi100200
14.06.2019 18:30
Известно, что девочек 1010002 %, а мальчиков 11112. сколько детей в классе. , скажите решения и по подробнее....
198912
08.09.2020 14:48
12.288битов перевести в байты и килобайты ...
0680820429
07.09.2020 14:19
Десятичное числа 148.58 перевести 2с/ч а затем 8с/ч...
DianaTesl
08.09.2020 14:01
Диаметр колёс робота равен 60 ММ. Робот проехал вперёд, при этом его колёса сделали три полных оборота. Сколько сантиметров проехал робот? ОЧЕНЬ...
cerf1709
30.09.2019 23:20
150 div 2 mod 30-90 mod 40 div. 10 можете решить ! (47 mod 8 + 150 div 30) mod 2. (49 mod 12-162 div 40) *( 19mod 3 + 50 div 4). (trunc(5.65) - round(-17.16))*in (-1.1)...
Pakimon4ikYT
30.09.2019 23:20
Настя выбрала в магазине открытки двух типов: по цене m и по цене d. всего у насти r рублей. составить программу, которая позволит получить всевозможные варианты покупок,...
Популярные вопросы
У трьох цехах заводу працює 125 робітник. Кількість робітників першого...
1
В тетради исписано 40 страниц, что составляет 5|8 всей тетради Сколько...
1
I work in a bank many years ago He lived in Moscow five years ago I liked...
1
Hi listened to the radio yesterday morning.задать во в времени,используя...
2
При делении одного ядра 235 92 U9 на два осколка выделяется энергия 200...
1
Что хотел сказать автор в рассказе «сгущённое молоко»...
1
собрать чемодан - einen Koffer für die Reise packen. Вам нужно нарисовать...
1
Монету подбрасывают несколько раз так что каждый раз с равной вероятностью...
3
Координацию и регуляцию у сложноорганизованных животных осуществляют...
2
Зробіть рисунок і обчисліть площу фігури , яка обмеженна даними лініями:...
3
// Внимание! Если программа не работает, обновите версию!
procedure pq(n:integer);
begin
if n<>0 then begin
var m:=Trunc(Sqrt(n));
Writeln(m);
pq(n-m*m)
end
end;