ПАСКАЛЬ
Составить программу для решения задач:
а) заполнить двумерный массив 10х10 целыми случайными числами в интервале (-5;20),вывести данный массив в виде таблицы.
б) найти сумму и произведение всех элементов данного массива.

буля4 буля4    3   21.04.2020 16:15    3

Ответы
Ирина8891 Ирина8891  13.09.2020 12:47

var A: array [1..10,1..10] of integer;

var i,j,s1: integer;

var s2: real;

begin

s1:=0;

s2:=1;

randomize();

For i:= 1 to 10 do

begin

 For j:= 1 to 10 do

 begin

 A[i,j]:=random(24)-4; // Поскольку интервал дан строгий (круглые скобки)

,

// если требовалось включить числа -5 и 20, замените эту строчку на следующую:  A[i,j]:=random(26)-5;

 write(A[i,j]:4);

 s1:=s1+A[i,j];

 s2:=s2*A[i,j];

 end;

 writeln();

end;

writeln('Сумма всех элементов: ',s1);

writeln('Произведение всех элементов: ',s2);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика