Паскаль. составить программу для решения следующей : даны числа a, b - целые (< > 0). сократить дробь a/b. сначала найти нод этих двух чисел. затем знаменатель и числитель разделить на нод.

0208 0208    3   30.08.2019 11:50    6

Ответы
gumballl1 gumballl1  26.08.2020 12:25
// PascalABC.NET 3.2, сборка 1427 от 24.04.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var p,q:integer;
  Write('Введите числитель и знаменатель: '); Read(p,q);
  var a:=abs(p);
  var b:=abs(q);
  while b<>0 do begin a:=a mod b; Swap(a,b) end;
  p:=p div a;
  q:=q div a;
  Writeln('Результат: ',p,'/',q)
end.

Пример
Введите числитель и знаменатель: 1440 16200
Результат: 4/45
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика