tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Паскаль. по данному числу n вычислите
Паскаль. по данному числу n вычислите 1+1/1! +1/2! +1/3! ++1/n!
andreyrekvinov
2 19.09.2019 19:40
2
Ответы
LeviAckerman13
08.10.2020 02:54
//PascalABC.NET
//Версия 3.3, сборка 1634
begin
var f: Integer->real:=x->range(1,x).Aggregate(Real(1),(x,y)->x*y);
var (sum,n):=(1.0,ReadInteger('n='));
for var i:=1 to n do sum+=1/f(i);
write(sum);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
HEPA3YMHblU
31.07.2019 05:10
Вчем состоит разница между презентации и страницами книги? а) переход между осуществляется с объектов б) на слайдах кроме текста могут содержаться мультимедийные объекты...
Александра24х4
31.07.2019 05:10
Основанием системы счисления, в которой справедливо равенство 122 + 42 = 214 является а) 4 б) 5 в) 6 г) 7 д) 8...
ksusha00008
29.10.2021 22:32
Информационное сообщение объёмом в 525 битов состоит из 75 символом. Какой информационный вес каждого символа этого сообщения...
lenatvoya
29.10.2021 22:38
Визначити, яку денну платню одержить співробітник заводу за виконану роботу, якщо йому нараховується S грн. за кожну з n годин, додається k відсотків за небезпечну роботу...
валера4711009
21.11.2019 15:46
Скорость передачи данных по некоторому каналу связи равна 256 000 бит/c. передача файла заняла 1,5 мин. определите размер файла в килобайтах...
annasafaryan87
21.11.2019 15:46
Напишите наибольшее число х, для которого ложно высказывание: не ((x 50) или не (х...
Aleksa4nick
21.11.2019 15:58
B. давид и нюанс подходит илюша к давиду и говорит: “давидроманыч, что такое нюанс? ”, а давид отвечает: “нюансом называется строка s такая, что если из нее удалить не более...
Crispino
25.08.2019 01:30
1) дан массив целых чисел из 12 элементов. напечатать все четные элементы. 2) дан массив целых чисел из 10 элементов. все элементы, кратные числу 10, заменить нулём. нужна...
nikitos22813371
25.08.2019 01:30
Составить программу рисования прямоугольной рамки вдоль края поля, начиная рисование из любого начального состояния исполнителя...
sanya3344
25.08.2019 01:30
решить на паскале полную ! массив из 15 элементов заполнен случайными числами из диапазона (-20; 20). найти максимальный элемент и его номер, вывести на экран элементы массива...
Популярные вопросы
Какое влияние оказывает петербург на героев романа преступление и наказание...
1
заранее Это задание) И надо дополнить фразы❤️ • Max dit que cette semaine......
1
Обчисліть 0,9∙( 0,8∙(- 1/5) – 21/25 ) + 2,25...
3
Тобы дать ответ на во почему Кадыргали Жалаиры написал: «Самым известным...
3
Тести.1. Нині льодовики є на всіх материках , крімваріанти відповідейА)АфрикиБ)АвстралііВ)Південної...
3
Яблука у результаті сушіння втрачають 84% своеї ваги. скільки потрібно...
1
Сколько граммов кремниевой кислоты получается при действии на силикат...
1
Предположим, что в экономике страны за один год было выпущено 100 товаров....
2
Калий хлорид масою 8 грам розчинили у води масою 196 грам яка масова...
2
S.61 Ein Tag im Buro. Ein Drama .Perfekt mit sein oder haben?...
2
//Версия 3.3, сборка 1634
begin
var f: Integer->real:=x->range(1,x).Aggregate(Real(1),(x,y)->x*y);
var (sum,n):=(1.0,ReadInteger('n='));
for var i:=1 to n do sum+=1/f(i);
write(sum);
end.