Паскаль) ) напишите программу вычисления среднего модулей двух введенных с клавиатуры чисел. программа должна использовать цикл while do. условия выхода их цикла-значение числа, равное 999.

Belka69hfchycv Belka69hfchycv    2   26.05.2019 07:00    17

Ответы
gasersazru gasersazru  22.06.2020 16:29
Var a,b,sg: real;
begin
readln(a);
readln(b);

a:=abs(a); b:= abs(b);
sg:= sqrt(a*b);

writeln(sg);
end.

Вот программа вычисления средней геометрической. Но про цикл не понял...
ПОКАЗАТЬ ОТВЕТЫ
ХАМЕЧОКЕ2036 ХАМЕЧОКЕ2036  22.06.2020 16:29
Program Zadacha;
Var a, b, i: Integer;
c: Real;
Begin
Write('a = ');
ReadLn(a);
Write('b = ');
ReadLn(b);
c := Sqrt(Abs(a) * Abs(b));
i := 0;
While i < 999 Do
i := i + 1;
WriteLn('Результат: ', c:5:2);
ReadLn;
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика

Популярные вопросы