Паскаль /! напишите программу которая заполняет массив из n=8 элементов случайными числами в диапазоне [0,20] , выводит его на экран, а затем меняет местами пары соеденёных элементов, кроме первого и последнего(2 с 3, 4с 5 и т. пример: массив : 5 16 2 13 3 14 18 17 реверс: 5 2 16 3 13 18 14 17

antonovakate2006 antonovakate2006    1   04.10.2019 20:40    32

Ответы
Nastia2k Nastia2k  11.09.2020 06:58

var

 a: array[1..10] of integer;

 i, n: integer;

begin

 n := 8;

 randomize;

 for i := 1 to N do

 begin

   a[i] := random(21);

   Write(a[i]:4);

 end;

 

 i := 2;

 while i <= N - 2 do

 begin

   Swap(a[i], a[i + 1]);

   i += 2

 end;

 

 Writeln;

 for i := 1 to N do

   Write(a[i]:4)

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика