("паскаль" информатика 9 класс) написать программу к (где нужно) 1.даны радиусы двух кругов r1 и r2.посчитайте площади двух катетов (s: =pi*r1*r2). посчитайте площадь кольца (s: =s2-s1),при условии ,что s> 0. (написать программу на паскале) 2.решите систему уравнений y= (4,если x-1< 0) и y= (3,если x-1> =0) написать программу на паскале . 3.заданы три числа ,известно ,что два равны между собой ,а третье отлично от них . составьте блок схему и напишите программу нахождение числа ,отличнго от двух других болел и тем не знаю ,так бы сам всё сделал. если хотите больше ,не надо на мне "отрываться" мне реально нужна . заранее

сьдвщы сьдвщы    1   17.06.2019 00:30    2

Ответы
DenisMarvin DenisMarvin  20.05.2020 15:28
Меньше в доту катай, все знать будешь :)
1)
uses crt;
var s,s1,s2,s3,r1,r2:real;
begin
writeln ('Введите радиус первого (маленького) круга:');
read (r1);
writeln ('Введите радиус второго (Большего, чем первый) круга:');
read (r2);
//pi - 3.14
s:=3.14*r1*r2 ;
writeln (s);
//s1 - Площадь первого круга, s2 - второго, s3 - кольца
s1:=3.14*sqr(r1);
s2:=3.14*sqr(r2);
if (s1=0) or (s2=0)
then writeln ('Одна из площадей равна нулю')
else begin s3:=s2-s1 ;  
writeln (s3); end
end.

2)
uses crt;
var x,y,x1,y1 :integer;
begin
writeln ('Введите целое значение x:'); // В программе используются только целые числа !!
read (x);
if (x-1)<0 
then y:=4 
else y:=3;
writeln (y);
end.

3)uses crt;
var  a,b,c:real ;
begin
writeln ('Последовательно введите 3 числа :');
read (a,b,c);
if (a<>b) and (b<>c) and (a<>c) 
then writeln ('Числа не равны') 
else
if (a=b) and (b=c) and (a=c) 
then writeln ('Числа все равны между собой')
else
if (a=b) and (b<>c) 
then writeln (c) 
else
if (a=c) and (c<>b) 
then writeln (b) 
else
if (b=c) and (c<>a) 
then writeln (a) 
end.

P.s. Писал на Pascal ABC. Блок-схему сделаешь сам, она не сложная. Удачи, инвакир :D
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика