tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Паскаль дана строка. если в этом
Паскаль дана строка. если в этом числе буква f встречается только один раз, выведите её индекс. если она встречается два и более раз, выведите индекс её первого и последнего появления. если буква f в данной строке не встречается, ничего не выводите.
mulin2000462345
3 20.09.2019 12:10
16
Ответы
apdemyanovozaif8
08.10.2020 04:32
Var i, n, i1, i2: integer;
s: string;
begin
readln(s);
n := length(s);
i1:=0;
i2:=0;
for i:=1 to n do
if s[i]='f' then
begin
if i1<1 then
i1:=i
else
i2:=i;
end;
if i1>0 then
if i2>0 then
writeln('Первая и последняя позиции f = ', i1, ' и ', i2)
else
writeln('Единственная позиция f = ', i1);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
pirozhkovanastya
19.02.2022 22:04
В чем плюсы Windows 11? И стоит ли переходить сейчас?...
Veratandashvili
19.02.2022 21:51
Можете это написать у себя на компьютере и сфотографировать и отправить мне как ответ просто нету компьютере а дз надо сделать...
khafizovtimur1oybznk
19.02.2022 21:37
2 Дана программа на языке Паскаль заполни пропуски Вывод на экранвадратов чисел от 1 до 35 нарисуйте в рамочках...
joker231341
06.09.2020 00:24
3) Укажите порядок действий при наличии признаков заражения компьютераа) Сохранить результаты работы на внешнем носителе.6) Запустить антивирусную программуа) Отключиться от...
lollo2003
06.09.2020 00:52
Объясните как получается значение числа в непозицийних системах счисления?...
ангелина123456543216
06.09.2020 00:50
надо Выбери верный ответ.1 нет верного ответа 2 проводные каналы3 беспроводные каналы ...
LinkolnPark1
03.08.2020 14:01
Как узнать пароль от компьютера не изменяв его ( на 10 винде)...
Ninick
03.08.2020 14:20
Формула Exel. Сумма делится на кол-во чисел в нейНапример: 3+4+6:3= или 3+4+2+6+2:5=...
annasoloveva02
18.07.2019 02:50
составить блок-схему и написать программу, определяющую является ли вводимое число - нечетным и двузначным одновременно это сложно...
пик124
18.07.2019 03:00
Вводятся 2 целых числа , в каком числе больше цифр?...
Популярные вопросы
Найти и длину окружности с радиусом 5 см.чему равна длина её дуги с градусной...
2
Решите , дано надо написать по рисунку, а потом доказательство и решение....
2
Чему равно произведение к × о × н × в × у × л × ь × с × и × я( ребус) ,...
2
Мальчики играли в боскетбол и волейбол один урок. в боскетболе они тренировались...
2
Подчеркнуть все члены предложения и указать чем они являются. 1. учитель...
1
мне , на листочке надо построить и решить графики функции: y=-3х²-2х поэтому...
1
Представьте квадратную шахматную доску. программа получает два целых числа...
3
Каким по счету стал африка в семье ппа биа и мма биа...
2
Твір на тему здобудеш освіту-побачиш більше світу...
3
Постройте таблицы значений для указанных функций. 2. y=2+3x^3-7/ x, x ∈...
1
s: string;
begin
readln(s);
n := length(s);
i1:=0;
i2:=0;
for i:=1 to n do
if s[i]='f' then
begin
if i1<1 then
i1:=i
else
i2:=i;
end;
if i1>0 then
if i2>0 then
writeln('Первая и последняя позиции f = ', i1, ' и ', i2)
else
writeln('Единственная позиция f = ', i1);
end.