Паскаль авс , при функции trunc() в паскале можно реализовать операции целочисленного деления и взятия остатка от деления. например: целочисленное деление - trunc(491/240) - результатом будет 2; остаток от деления - 491-240*trunc(491/240) - результатом будет 11. используя функцию напишите программу, считающую сдачу в денежной системе (в этой денежной системе 1 фунт стерлингов равен 20 шиллингам, а 1 шиллинг равен 12 пенсам). напишите программу, в которой в трёх константах хранится стоимость товара. одна константа - фунты (целое значение больше нуля), вторая - шиллинги (значение от 0 до 19), третья - пенсы (значение от 0 до 11). ещё в трёх таких же константах хранится плата покупателя. используя одну целочисленную переменную, программа должна сосчитать и вывести на экран сдачу в фунтах, шиллингах и пенсах. не использовать условный оператор программа должна быть написана на паскале авс

AngelinaLOL18 AngelinaLOL18    1   19.06.2019 05:40    0

Ответы
Kosty12541 Kosty12541  15.07.2020 15:30
В одном фунте 20*12=240 пенсов.
Стоимость товара: F1 - фунты, S1 - шиллинги, P1 - пенсы
Плата покупателя: F2 - фунты, S2 - шиллинги, Р2 - пенсы
Х - сдача в пенсах

const
  f1=11;
  s1=5;
  p1=3;
  f2=12;
  s2=10;
  p2=0;
var
   x:integer;
begin 
x:=f2*240+s2*12+p2-f1*240-s1*12-p1; 
writeln('Сдача:'); 
writeln('фунтов ',trunc(x/240)); 
x:=x-240*trunc(x/240); 
writeln('шиллингов ',trunc(x/12)); 
x:=x-12*trunc(x/12); 
writeln('пенсов ',x);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика