tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Паскаль авс.net программы . массивы
Паскаль авс.net программы . массивы подсчитайте количество элементов одномерного массива, абсолютная величина которых совпадает со своим номером.
mariyakohtuk
1 27.08.2019 22:10
0
Ответы
Артемошка1111
05.10.2020 23:31
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadSeqIntegerWhile('Вводите числа, окончание - 0:',x->x<>0).ToArray;
Writeln('Искомое количество: ',a.Where((x,i)->abs(x)=i+1).Count)
end.
Пример
Вводите числа, окончание - 0: 3 2 7 11 -6 3 -7 16 0
Искомое количество: 2
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Maara
28.01.2021 14:55
написать программу на python Создай базу интересов. Сначала у первого пользователя запрашиваем число интересов, которое он хочет ввести, затем он вводит их и они добавляются...
sergeyfedorov2
14.04.2021 11:15
Составь слова используя буквы данные в таблице информатика 4...
АльбукаеваЗарема
27.02.2020 13:14
5. Постройте изображения предметов в собирающей линзе....
ОляОля123456789
02.12.2020 09:27
Какова роль инструмента Следуй за мной в построении конусса и сферы...
kektuber222owf6bv
02.12.2020 09:26
Заполните таблицу Документ.txt Хобби Книга1.xlsx Документ.docx Тесты Учёба Рабочие документы...
арсен157
02.12.2020 09:23
Напишите форматы типов данных: [ ] € 8 000 5:20:007712305,17Привет!...
отличник733
25.07.2019 05:50
Если маска подсети 255.255.255.224 и ip-адрес компьютера в сети 162.198.0.157, то номер компьютера в сети равен? !...
Dima22022005
17.12.2021 20:04
решить! 1) Точка Е середина отрезка AC, AB=CD, кут 1= кут 2. Найти кут 3, если кут 4=35° 2) Известно, что AB=CD, кут 1= кут 2 , кут 3 = кут 4. Найти длину отрезка АЕ, если AC=4см....
zhannursadykbek
17.12.2021 20:04
привидите примеры процессов, в которых в результате взаимодействиятел мяч приходит в движение или меняет направление движения...
Danich55
17.12.2021 20:04
Почему за три года урожай на огороде Григория Николаевича стал хуже, хотя почва сначала была богатой на необходимые растениям вещества? Назовите не меньше двух причин....
Популярные вопросы
Печатный станок что это и что такое жоский диск?...
3
Краткое сочинение на тему недаросль...
2
Синтаксический разбор пальцами исписал мичман в книжке первую страницу....
1
Зробіть ідейно художній аналіз в. листопад рідному привзов ю нехай на світі...
1
Какое количество гамет может образовывать личность с генотипом bbcc...
2
Разобрать предложение по составу: в толще бирюзовой воды встают колоссальные...
1
Составьте предложение со словами: тот час,тотчас,по-видимому ,по видимому,отчасти,...
3
Решить уравнение : 5(0,5p+0,72)=1,5(p+4)...
2
Вы идете по лесу. замечаете,что между деревьями натянута паутина. она не шолохнется....
2
Кому принадлежат реплики? ночь всю така дрянь в глаза лезла. имей сердце,имей...
2
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadSeqIntegerWhile('Вводите числа, окончание - 0:',x->x<>0).ToArray;
Writeln('Искомое количество: ',a.Where((x,i)->abs(x)=i+1).Count)
end.
Пример
Вводите числа, окончание - 0: 3 2 7 11 -6 3 -7 16 0
Искомое количество: 2