Pascalabc, составьте программу, которая введенное с клавиатуры слово выводит в конце строки, а затем по буквам, начиная с первой, переставляет в начало строки.

dima201100d dima201100d    2   27.05.2019 01:50    0

Ответы
Lena5737488 Lena5737488  23.06.2020 18:30
)напиши куда слово встовлять(вначало, вконец, посередине...); 
program z2; 
var s,s1:string; 
a:integer; 
begin 
write('Введите слово: ');read(s1); 
write('Введите строку: ');read(s); 
s:=s+' '; 
a:=length(s); 
writeln(a); 
insert(s1,s,a+1); 
writeln('Преобразованная строка: ',s); 
end. 
2) 
program z1; 
var s:string; 
i,kol:integer; 
begin 
writeln('Введите строку'); 
read(s); 
kol:=0; 
for i:=1 to length(s) do 
if (s<>' ')and(s<>'1')and(s<>'2')and(s<>'3')and 
(s<>'4')and(s<>'5')and(s<>'6')and(s<>'7')and 
(s<>'8')and(s<>'9')and(s<>'0') then inc(kol); 
writeln(Kol); 
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика