tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Pascal, вывести количество
Pascal, вывести количество простых чисел от n до m где n> 2, а m< 30000. с объяснением
ytt2
2 28.05.2019 10:50
0
Ответы
GB001
25.06.2020 21:24
var
m,n,i,j:integer;
bool:boolean;
begin
readln(n,m); //читаем Н и М
for i:=n to m do begin // От Н до М выполняем цикл
bool:=false; // Обнуляем переменную для каждой итерации
for j:=2 to i-1 do
begin // Проверяем, делится ли число на числа, которые находятся в промежутку от 2 до это число -1
if (i mod j=0) then bool:=true; //если делится, тогда bool:=true
end;
if (bool = false) then write(i,' '); //если bool = false, значит это число делится только на себя и на 1, а значит оно простое и выводим это число
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
VikaYastremska
30.04.2020 23:58
Целыми часами являются: 3,3/29,корень из 2;1,85;-19....
Tatyna83
30.04.2020 23:58
ЛЮДИ НУЖНО СДЕЛАТЬ В ИКСЕЛЕ ,А Я ВООБЩЕ В НЕМ НЕ СЕКУ!...
kopechenkina
09.04.2020 06:51
Что такое ветвление? * слово, записанное буквами русского латинского алфавита возможна группа слов, соединенных подчеркиванием это набор зарезервированных символов и ключевых слов,...
Maks2222222222
02.10.2019 11:26
Умистера лысый из бразерса есть карточки, на каждой стороне которых нарисована или машина или какой-то зверь. карточек с животными 10, карточек с машинами 13, карточек, где на одной...
evauvanova1998
02.10.2019 12:10
Переведите число 1001111 в десятичную систему счисления...
юлия1628
18.03.2021 10:33
Составьте программу вывода на экран числа Z равная X*Y если X больше Y иначе вывести Z равна X÷Y. X и Y целые числа....
AgafAl
20.05.2021 16:18
На цьому етапі відбувається збір інформації та матеріалів організаційнийпрактичнийузагальнюючийпошуковийподання результатів...
solodovnikovay124
20.05.2021 16:17
ЗАДАЧА В Python(ПИТОН УМОЛЯЮ. КАК ЭТА ЗАДАЧА БУДЕТ ВЫГЛЯДИТЬ В ПИТОНЕ. ...
nastya06nastik
20.05.2021 16:16
ЗАПИШИТЕ ВЫРАЖЕНИЕ НА ЯЗЫКЕ ИМЕННО КАК БУДЕТ ВЫГЛЯДИТЬ В ПИТОНЕ. ...
tokio272
20.05.2021 16:16
Яких властивостей немає у напису * textсommandwidthbgfgfontactivebackgroundactiveforegroundbdheight...
Популярные вопросы
томендеги фразеологизмдердин ишинен достык,бирлик,татулыкка катыстыларын терип...
2
Данышпан Аттылы Садақ атқыштар Баспана Билігін берген составить предложение на...
1
1.Дайте определения терминов: акыны, жырау, шешены, жоктау, естирту 2.Заполните...
1
Выдели метафору в цитате. Домашние звериСтояли в пещере,Над яслями теплая дымка плыла.метафоракаак...
3
не могу никак найти ответы...
3
написать эссе Юридический состав правонарушения...
3
Сольфеджиоукажите нужный размер в музыкальных примерах ...
3
Задание 1. ответь на вопросы. 1. Алаш. Правительство Алашорды. Что вы знаете о...
1
Почему простакова уговаривает сына получиться для вида?Вопрос по комедии Недоросль...
1
Составь предложение:горный махровый...
1
m,n,i,j:integer;
bool:boolean;
begin
readln(n,m); //читаем Н и М
for i:=n to m do begin // От Н до М выполняем цикл
bool:=false; // Обнуляем переменную для каждой итерации
for j:=2 to i-1 do
begin // Проверяем, делится ли число на числа, которые находятся в промежутку от 2 до это число -1
if (i mod j=0) then bool:=true; //если делится, тогда bool:=true
end;
if (bool = false) then write(i,' '); //если bool = false, значит это число делится только на себя и на 1, а значит оно простое и выводим это число
end;
end.