tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Pascal! найти среднее арифметическое
Pascal! найти среднее арифметическое отрицательных элементов массива. заменить на него минимальный элемент.
DIMONSTERUSp
3 11.07.2019 12:10
11
Ответы
загадка28
17.09.2020 20:56
Var a: array[1..10] of integer;
var i, col, ans:integer;
begin
ans:=0;
col:=0;
for i:=1 to 10 do
begin
readln(a[i]);
if a[i] < 0 then
begin
col:=col+1;
ans:=ans+a[i];
end;
end;
writeln(ans/col);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
arty181118
16.02.2022 04:01
сколько раз выполняется цикл? запиши, чему будет равна переменная (2) a= 3; b = 7, в то время как a b: a += 1 сколько раз-? а=? a = 4; b = 6, в то время как a b: a +=b сколько...
Jullia123123
19.05.2019 14:20
1) составьте прграмму,в которой определялось бы является ли введеный символ гласной или согласной буквой латинского алфавита. 2) составьте программу-меню,выводящую расписание...
gg228
03.12.2020 23:57
Нужно сделать задания с программирования C++ ( )...
Parf21
03.12.2020 23:57
РЕШИТЬ. Составьте таблицу истинности для следующей логической функции F=X∧Y¬∨ X¬∧Y...
ixnivoodoo
03.12.2020 23:56
Написать программу для Си, выделив под массив динамически память. Обращаться к элементам массива необходимо используя указатель. В одномерном массиве вычислить сумму элементов...
vitalyrtss
03.12.2020 23:56
решить и 6 номер по информатике >...
RoyalTeam698
03.12.2020 23:56
ставлю составить алгоритм вычисляющий сумму возрастов вашей семьи из этих чисел 11, 15, 21, 40, 41, 61 большое:)...
milana23456789
12.03.2022 12:39
Поддерживает ли Minecraft earth на xiaomi redmi note 9 pro Ps:не по теме сразу баню!...
Sakinatabdylaeva
12.03.2022 12:42
4. Напишите код программы для решения следующей задачи: Задача: Даны стороны прямоугольника. Составьте программный код, который определит площадь прямоугольника (S) и периметр...
хорошист378
12.03.2022 13:05
с этим :Составить алгоритм для исполнителя Чертежник, (чертить) ваше полное имя. Имя Тимофей...
Популярные вопросы
От следующих глаголов образуйте сначала причастия,затем деепричастия...
3
по контрольной работе РЕШИТЕ ВСЕ правильно....
3
1. What are the children doing?2.Have you got any ofthese gargets ?3.If...
2
Дать определение каждому из свойств...
1
Der oder die? Ergänze. 1. Das ist Bruder von Oliver. 2. Schwester von Oliver...
2
Даны точки A(0;1;-1), B(1;-1;2), C(3;1;0), D(2;-3;1). Найдите сумму векторов...
2
20см 4см 5 разів більше за його ширину обчисліть об єм даного паралелепіпеда...
1
Яйцо,кольцо письмецо,сердце,бахчой,сдачей,каланчой,парчой,плещом,борщем,товарищем,плющом,лужей,стужей,ужом,ужем,...
3
Найти первый и шестой член арифметической прогрессии a8= 64 :a10= 50 а1=?...
2
80 слов. В работе используйте вводные конструкции, однородные члены предложения...
3
var i, col, ans:integer;
begin
ans:=0;
col:=0;
for i:=1 to 10 do
begin
readln(a[i]);
if a[i] < 0 then
begin
col:=col+1;
ans:=ans+a[i];
end;
end;
writeln(ans/col);
end.